SurveyResult

Sep 26, 2007 at 1:17 AM
Hi Steve,

On other thing regarding SurveyResult. When I am using VS2005 to develop my ASP.NET apps, the control below always raises an error in VS2005 which says "Element 'SurveyResult' is not a known element. This can occur if there is a compilation error in the Web site". However if I run the page, then it works just fine, so I know that the dll I have must be working correctly.

<sstchur:SurveyResult id="srMySurvey"
SurveyFile="/surveys/survey/survey.xml"
AnswersFile="/surveys/answers/answers.xml"
Stylesheet="stylesheet.xsl"
XQuery1="//WebSurvey/Group/Question"
XQuery2="//Answers/AnswerSet/Answer"
runat="server" />

Any thoughts / suggestions?

Regards
Dave
Coordinator
Oct 2, 2007 at 4:55 PM
Hmm,

I've not run into this myself. Do you have more specific information about how to repro this issue?

-Steve
Apr 1, 2008 at 9:21 PM
Edited Apr 1, 2008 at 9:21 PM


sstchur wrote:
Hmm,

I've not run into this myself. Do you have more specific information about how to repro this issue?

-Steve


I am having the same issue. Has anybody found an answer to this? Thank you.
Coordinator
Apr 9, 2008 at 8:15 PM
Can you offer specific repro steps so that I can try to duplicate this issue locally?

Thanks,
-Steve
Apr 11, 2008 at 11:08 AM
I too get the same problem. I am using a master page, but that should have no effect. You have asked for steps to reproduce the problem, All I did was follow your instructions to add the control. It compiles and works fine, except for this mildly annoying issue.

In fact, in design view, I get an error on both the WebSurvey element and the SurveyResult.
On WebSurvey I get 'Error Rendering Control - Survey1 An unhandled exception has occurred. Object reference not set to an instance of an object.'

On SurveyResult I get "Error Creating Control - Content1 'Survey.xml' could not be set on property 'SurveyFile'"

Thanks, Jules